25ответ(ов) в теме
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
1
13:51
Версия WP-Recall: 16.17.3

Нажимаю на иконку "загрузить аватар", выбираю картинку, жму "загрузить", а потом ничего не происходит.
Где искать решение? Какие варианты тут могут быть.

0
garry
не в сети 56 минут
На сайте с 04.01.2014
Участник
Тем 145
Сообщения 2860
2
13:53

Посмотреть в консоле браузера, какие ошибки там есть.

1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
3
14:04

Ошибок в консоли нет.

0
Владимир (Otshelnik-Fm)
не в сети 42 минуты
На сайте с 27.01.2013
Участник
Тем 43
Сообщения 18498
4
14:07

Здравствуйте.

Воспользуйтесь поиском по форуму, подобные вопросы были не раз. Помочь на локальном сервере невозможно.
Перенесите на хостинг - дадите ссылку на проблему, будет возможность помочь.
Проведите самодиагностику, четко следуя всем пунктам руководства:

Вы не можете просматривать опубликованные ссылки
1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
5
17:54

Попробовал в своей теме закомментить вот эту строчку:

<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />

И после этого, конечно, все поплыло, но загрузка аватара стала работать. Тут дело значит в стилях? Может быть такое, что какой то стиль перекрывает всплывающее окно загруженного изображения?

0
Андрей CS
не в сети 3 часа
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 15991
6
19:25

Alexxx999 сказал(а)
Может быть такое

может

1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
7
21:29

Проверял в стилях нет ничего особенного, там ведь только внешний вид меняется...

0
garry
не в сети 56 минут
На сайте с 04.01.2014
Участник
Тем 145
Сообщения 2860
8
07:03

Добавьте в стили через консоль тегу body

body {
    display: none;
}

Ничего особенного, но где же сайт)

PS
Андрей, мне какая-то фигня от вконтакта вылезла при обновлении странички...сервер недоступен или типо того. Не успел понять и перевести. Хром, винда 10. Буквально секунды.

Редакции сообщения
22.02.2019 07:07garryПричина: не указано
22.02.2019 07:07garryПричина: Дополнил
1
Владимир (Otshelnik-Fm)
не в сети 42 минуты
На сайте с 27.01.2013
Участник
Тем 43
Сообщения 18498
9
10:21

Otshelnik-Fm сказал(а)
Проведите самодиагностику, четко следуя всем пунктам руководства:

Вы не можете просматривать опубликованные ссылки

не делали? Там же сказано что нужно проверить на дефолтной ВП теме. Так вы исключите влияние своей темы. т.к. не все ВП темы написаны верно - лучше проверить на теме от самих ВП разрабов

1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
10
10:33

garry сказал(а)
Добавьте в стили через консоль тегу body

body {
    display: none;
}

Ничего особенного, но где же сайт)

PS
Андрей, мне какая-то фигня от вконтакта вылезла при обновлении странички...сервер недоступен или типо того. Не успел понять и перевести. Хром, винда 10. Буквально секунды.

Это вы по какой теме? Прикол чтоли?)

0
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
11
10:34

Otshelnik-Fm сказал(а)

Otshelnik-Fm сказал(а)
Проведите самодиагностику, четко следуя всем пунктам руководства:

Вы не можете просматривать опубликованные ссылки

не делали? Там же сказано что нужно проверить на дефолтной ВП теме. Так вы исключите влияние своей темы. т.к. не все ВП темы написаны верно - лучше проверить на теме от самих ВП разрабов

У меня изначально на локальном сервере с темой все в порядке и загружалось, но после загрузки на хостинг такая фигня. Буду дальше разбираться/копаться...

0
Владимир (Otshelnik-Fm)
не в сети 42 минуты
На сайте с 27.01.2013
Участник
Тем 43
Сообщения 18498
12
10:45

1. отключаем все плагины кроме реколл
2. переключаемся на дефолтную ВП тему.

Смотрим. Если всё ок - то активируем тему свою - смотрим вновь. Если ок - то активируем сторонние плагины - ищем виновника.
Эти рекомендации справедливы для всех случаев поиска конфликта при любом плагине.

1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
13
16:10

Отключил старую тему, перешёл на другую - там все загружается. Включил снова свою старую тему - там нет. Собственно, моя тема виновник. Может надо какой нибудь скрипт в шапку добавить или еще чего нибудь? Как я упоминал ранее, если закомментить строчку с подключением файла стилей загрузка в теме работает, а так нет.

Редакции сообщения
22.02.2019 17:57Андрей CSПричина: не указано
0
Владимир (Otshelnik-Fm)
не в сети 42 минуты
На сайте с 27.01.2013
Участник
Тем 43
Сообщения 18498
14
16:19

Мы, не видя, гадать не можем. Вы должны это понимать.
Обратитесь к разработчику темы, или используйте другую.

1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
15
16:25

Написал вам в личку

Редакции сообщения
22.02.2019 17:57Андрей CSПричина: не указано
0
Андрей CS
не в сети 3 часа
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 15991
16
18:05

для начала отключите на своем сайте минимизацию и объединение файлов в настройках плагина wp-recall

0
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
17
18:19

Минимизацию скриптов отключил, а объединение файлов это где находится?

Редакции сообщения
22.02.2019 18:23Андрей CSПричина: не указано
0
Андрей CS
не в сети 3 часа
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 15991
18
18:25

Прекратите постоянно цитировать предыдущий ответ, это совершенно неуместно.

Alexxx999 сказал(а)
Отключил старую тему, перешёл на другую - там все загружается

какую именно тему вы отключали? речь о теме wp или о теме ЛК?

1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
19
18:26

WP тему конечно отключал, смотрел на другой. Проблема только с текущей возникает. На какой-то определенный момент возникла. Жаль я не зафиксировал когда.

0
Андрей CS
не в сети 3 часа
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 15991
20
18:28

а если включить дефолтную тему ЛК?

1
Андрей CS
не в сети 3 часа
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 15991
21
18:34

смотрите в исходный код страницы ЛК, html-код контента страницы повторяется два раза, тема работает неверно

1
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
22
18:38

Андрей CS сказал(а)
смотрите в исходный код страницы ЛК, html-код контента страницы повторяется два раза, тема работает неверно

У меня Sunshine тема Recall, но я сделал вывод ЛК на другой странице темы Wordpress. Аватар и все остальное в область сайдбара перенес и половину скрыл.

Если повторяется, то можно отключить стандартное выполнение кода? И оставить только мое которое сейчас.

0
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
23
18:43

Понял как повторяется. В сайдбаре и в контенте справа. И вот как отключить выполнение кода от аватара в контенте? Там по идее скрыто меню и аватар стилями/

Там просто выводится шорткодом, в этом сложность

Редакции сообщения
22.02.2019 18:44Alexxx999Причина: не указано
0
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
24
18:51

Попробовал вывести ЛК в другом месте там аватар загружается.
Попробую создать чистый шаблон для личного кабинета и отпишу.

0
Alexxx999
не в сети 2 года
На сайте с 17.02.2019
Бан
Тем 18
Сообщения 85
25
19:01

Ну все, ребята, понятно теперь стало. Создал другую страницу WP, вывел там шорткод, применил спец. шаблон для личного кабинета(который сам создал) и теперь аватар загружается. Спасибо вам за подсказки. Можем закрывать тему.

0
Тема закрыта. Публикация новых сообщений запрещена.