Домой Wp-Recall WP-Recall: Проблемы и решения Проблема с медиа-загрузчиком
23 ответ(ов) в теме
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
1
15:58
Версия WP-Recall:16.18.20

Привет. Проблема с медиа-загрузчиком заключается в том, что он срабатывает не всегда. Т.е. можно создать одну запись и к ней добавить через медиа-загрузчик несколько фото без проблем, но стоит еще одну сразу же начать создавать запись, как медиазагрузчик не срабатывает. Вообще, у меня возможность создания записи выведены в двух местах: через профиль и на отдельной странице сайта через шорткод соответственно, поэтому бывает еще так, что через профиль, к примеру, если добавлять запись фото загружаются, а через отельную страницу - нет. И наоборот. В общем - хочет загружает, не хочет - нет. Примечательно, что миниатюра записи работает без нареканий. Кто подскажет в чем может быть проблема?

0
Владимир (Otshelnik-Fm)
не в сети 8 часов
На сайте с 27.01.2013
Модератор
Тем 30
Сообщения 16934
2
16:11

Здравствуйте.

Функционал у пользователей работает. Надо искать что в вашем случае мешает.

Выполните эти рекомендации - возможно найдете причину

Вы не можете просматривать опубликованные ссылки

Ну и ели не найдете причину - дайте больше деталей по воспроизведению - проверим у себя. Постараемся воспроизвести по вашим шагам

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
3
19:47

Выполнил все рекомендации, что указаны в статье, на которую вы сослались. Сначала выставил в настройках все по дефолту: поставил стандартный шаблон ЛК, все настройки выставил, как было изначально, отключил дополнение Вп-рекал "фильтр пользователей". Попробовал загрузить изображения, итог тот же: иногда загружаются изображения, иногда нет. Далее пункт 2. Отключил все плагины, решил проверить, результата не дало. Сменил шаблон на дефолтный вордпрессовский "Twenty Twenty", результат все тот же. Также выполнил пункт 3 - загрузил изображения из админки, загрузилось все без проблем. В общем, проблему решить не удалось.

Не совсем понял, что значит "дайте больше деталей по воспроизведению", это видимо описать последовательность моих действий после того, как я добавил плагин? Если да, то я особо ничего не менял,так, стили немного, добавил вывод информации произвольных полей пользователя в списке пользователей, включил дополнение "фильтр пользователей", поставил бесплатный шаблон личного кабинета "Simple Theme", добавил и настроил пару форм публикации, изменил порядок вкладок в личном кабинете и удалил несколько ненужных дополнений, которые подключаются по дефолту. Вроде все.

К слову, если гость создает запись, то почти всегда изображения загружаются, из 10 раз, два раза только не сработало, пришлось страницу перезагружать и тогда срабатывает загрузка изображения. А если зарегистрироваться и в ЛК выкладывать запись, то почти чаще возникает данная проблема.

В общем еще не знаю, что рассказать. Вот ссылка на сайт

Вы не можете просматривать опубликованные ссылки

, чтобы непосредственно увидеть как выглядит этот конфликт

0
Владимир (Otshelnik-Fm)
не в сети 8 часов
На сайте с 27.01.2013
Модератор
Тем 30
Сообщения 16934
4
23:16

На данной странице, ссылку на которую вы дали - куда смотреть?

Плагины кеширования стоят?

Вы говорите о формах публикации - где они стоят? Они на разных страницах?

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
5
09:24

Плагин кэширования стоял, но я его отключил и потом удалил, новый еще не устанавливал

Вы не можете просматривать опубликованные ссылки
Вы не можете просматривать опубликованные ссылки
0
Владимир (Otshelnik-Fm)
не в сети 8 часов
На сайте с 27.01.2013
Модератор
Тем 30
Сообщения 16934
6
09:52

В логах ошибок вебсервера может есть что?

А если отключить really-simple-captcha?

Возможно еще что-то у вас что-то с кешированием. А если перед каждой отправкой вначале кеш браузера чистить?

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
7
10:22

Если капчу отключить, то результата это не дает. Плагинов кэширования больше нет, так же отключен кэш от Рекалл. Если чистить кеш браузера и добавлять фото то получается то же самое.
REST API выдает ошибку

Запрос к REST API неудачен из-за ошибки.
Ошибка: cURL error 28: Operation timed out after 10001 milliseconds with 0 out of -1 bytes received (http_request_failed)

Так же ВП пишет, что мой сайт не может выполнить петлевой запрос "Ошибка: cURL error 28: Operation timed out after 10001 milliseconds with 0 out of -1 bytes received (http_request_failed)"

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
8
11:44

Не совсем понял при чем тут REST API.
Код скрипта загрузки неизменен, он или работает или не работает, пробуйте искать закономерности в загружаемых изображениях, возможно, не загружаются какие то определенные изображения, по весу, типу и тп?

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
9
12:09

пробуйте искать закономерности в загружаемых изображениях, возможно, не загружаются какие то определенные изображения, по весу, типу и тп

Уже проверенно - одно и то же фото то загружается то нет

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
10
12:11

смотрите в консоль браузера, что туда пишется при неудаче

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
11
12:31

смотрите в консоль браузера, что туда пишется при неудаче

scripts.js?ver=16.18.20:57 Uncaught ReferenceError: wp is not defined
at rcl_setup_async_upload (scripts.js?ver=16.18.20:57)
at core.js?ver=16.18.20:35
at Array.forEach ()
at rcl_do_action (core.js?ver=16.18.20:34)
at rcl_init_public_form (scripts.js?ver=16.18.20:365)
at (index):585

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
12
12:40

отключайте другие плагины, переключайтесь на дефолтную тему, проверяйте работу в таком режиме

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
13
12:49

отключайте другие плагины, переключайтесь на дефолтную тему, проверяйте работу в таком режиме

уже выше это советовали, отписался ведь, что безрезультатно. Отключил все плагины и сразу пошел проверять - бестолку, сменил тему на дефолтную Twenty, тоже не дало нужного результата

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
14
12:56

сделайте это еще раз и сообщите как будет готово, посмотрю сам

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
15
12:59

Готово. Через эту страницу добавляются записи

Вы не можете просматривать опубликованные ссылки

Учтите, что фото то загружаются, то нет, сначала могут загружаться, но стоит перезагрузить страницу, как появляется данная проблема. И еще: если добавлять запись, как зарегистрированный пользователь, то проблема появляется в разы чаще

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
16
13:02

в настройках поля "Подробное описание запроса" пробуйте включить html или визуальный редактор

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
17
13:14

Готово

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
18
13:16

проблема ушла?

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
19
13:22

проблема ушла?

Да, я заметил, что если включить любой из трех пунктов (html, визуальный редактор или медиазагрузчик) проблема не возникает. Спасибо. А через стили скрыть можно визуальный реактор на странице добавления записи? Потому что я не хочу, чтобы пользователи играли со шрифтом и т.д.
Потому что, как я понял если не включать один из выше перечисленных пунктов, то возникает вот такая проблема, но в то же время, мне не визуальный редактор, не html не нужны...

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
20
13:49

ясно, проблема будет исправлена в ближайшем обновлении, сегодня-завтра, пока можно стилями скрыть

0
s.rom97
не в сети 2 недели
На сайте с 23.04.2017
Участник
Тем 7
Сообщения 20
21
14:04

проблема будет исправлена в ближайшем обновлении

Понял, спасибо, за помощь. Кстати, при обновлении плагина кастомизация плагина слетает, здесь есть где-то мануал, как с этим бороться? Я просто особо в этом не понимаю, поэтому спрашиваю. Или отдельную тему надо создавать? Или самому сидеть искать?) А так по этой теме вопрос можно закрывать

0
Андрей CS
не в сети 11 часов
На сайте с 30.11.-0001
Администратор
Тем 71
Сообщения 14362
22
14:31

если вносить изменения в код плагина, то конечно при обновлении все слетит, надо учиться кастомизировать без изменения кода, через хуки, фильтры, перезаписью правил css, материал об этом есть, надо искать

0
Владимир (Otshelnik-Fm)
не в сети 8 часов
На сайте с 27.01.2013
Модератор
Тем 30
Сообщения 16934
23
14:45

Как редактировать плагин WordPress, чтоб при его обновлении изменения не потерялись

Вы не можете просматривать опубликованные ссылки

s.rom97 сказал(а)
А так по этой теме вопрос можно закрывать

Закрыто.

0
Тема закрыта. Публикация новых сообщений запрещена.