Здравствуйте!
Периодически ложится ВДСка - 500 ошибка, служба сервера баз данных останавливала свою работу из-за нехватки ОЗУ.
Это говорит хостер и еще когда они стали анализировать причину то выяснилось:
Проверили и понаблюдали некоторое время за работой сервера. В логах ошибок сайта наблюдаем запросы к не существующим таблицам БД, такого плана:
[Sun Jun 23 08:21:55.871740 2019] [:error] [pid 8027] [client 000.000.00.000:40984] \xd0\x91\xd0\xb0\xd0\xb7\xd0\xb0 \xd0\xb4\xd0\xb0\xd0\xbd\xd0\xbd\xd1\x8b\xd1\x85 WordPress \xd0\xb2\xd0\xbe\xd0\xb7\xd0\xb2\xd1\x80\xd0\xb0\xd1\x82\xd0\xb8\xd0\xbb\xd0\xb0 \xd0\xbe\xd1\x88\xd0\xb8\xd0\xb1\xd0\xba\xd1\x83 Table 'admin_neuroda_wp.wp_d78f_wau_access' doesn't exist \xd0\xb2 \xd0\xbe\xd1\x82\xd0\xb2\xd0\xb5\xd1\x82 \xd0\xbd\xd0\xb0 \xd0\xb7\xd0\xb0\xd0\xbf\xd1\x80\xd0\xbe\xd1\x81 SELECT wau_access.* FROM wp_d78f_wau_access AS wau_access WHERE wau_access.user_id = '0' ORDER BY wau_access.access_id DESC, \xd0\xb2\xd1\x8b\xd0\xbf\xd0\xbe\xd0\xbb\xd0\xbd\xd0\xb5\xd0\xbd\xd0\xbd\xd1\x8b\xd0\xb9 require('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, wau_init_user, WAU_User->__construct, Rcl_Query->get_results, Rcl_Query->get_data
[Sun Jun 23 08:21:56.871694 2019] [:error] [pid 8029] [client 000.000.00.000:40986] \xd0\x91\xd0\xb0\xd0\xb7\xd0\xb0 \xd0\xb4\xd0\xb0\xd0\xbd\xd0\xbd\xd1\x8b\xd1\x85 WordPress \xd0\xb2\xd0\xbe\xd0\xb7\xd0\xb2\xd1\x80\xd0\xb0\xd1\x82\xd0\xb8\xd0\xbb\xd0\xb0 \xd0\xbe\xd1\x88\xd0\xb8\xd0\xb1\xd0\xba\xd1\x83 Table 'admin_neuroda_wp.wp_d78f_wau_accounts' doesn't exist \xd0\xb2 \xd0\xbe\xd1\x82\xd0\xb2\xd0\xb5\xd1\x82 \xd0\xbd\xd0\xb0 \xd0\xb7\xd0\xb0\xd0\xbf\xd1\x80\xd0\xbe\xd1\x81 SELECT wau_accounts.* FROM wp_d78f_wau_accounts AS wau_accounts ORDER BY wau_accounts.account_id DESC, \xd0\xb2\xd1\x8b\xd0\xbf\xd0\xbe\xd0\xbb\xd0\xbd\xd0\xb5\xd0\xbd\xd0\xbd\xd1\x8b\xd0\xb9 include('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, wau_init_user, WAU_User->__construct, WAU_Accounts_Walker->__construct, Rcl_Query->get_results, Rcl_Query->get_data
[Sun Jun 23 08:21:56.872015 2019] [:error] [pid 8029] [client 000.000.00.000:40986] \xd0\x91\xd0\xb0\xd0\xb7\xd0\xb0 \xd0\xb4\xd0\xb0\xd0\xbd\xd0\xbd\xd1\x8b\xd1\x85 WordPress \xd0\xb2\xd0\xbe\xd0\xb7\xd0\xb2\xd1\x80\xd0\xb0\xd1\x82\xd0\xb8\xd0\xbb\xd0\xb0 \xd0\xbe\xd1\x88\xd0\xb8\xd0\xb1\xd0\xba\xd1\x83 Table 'admin_neuroda_wp.wp_d78f_wau_access' doesn't exist \xd0\xb2 \xd0\xbe\xd1\x82\xd0\xb2\xd0\xb5\xd1\x82 \xd0\xbd\xd0\xb0 \xd0\xb7\xd0\xb0\xd0\xbf\xd1\x80\xd0\xbe\xd1\x81 SELECT wau_access.* FROM wp_d78f_wau_access AS wau_access WHERE wau_access.user_id = '0' ORDER BY wau_access.access_id DESC, \xd0\xb2\xd1\x8b\xd0\xbf\xd0\xbe\xd0\xbb\xd0\xbd\xd0\xb5\xd0\xbd\xd0\xbd\xd1\x8b\xd0\xb9 include('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, wau_init_user, WAU_User->__construct, Rcl_Query->get_results, Rcl_Query->get_data
Идут запросы к таким таьлицам:
1 'admin_neuroda_wp.wp_52e4_wau_access'
1 'admin_neuroda_wp.wp_52e4_wau_accounts'
12 'admin_neuroda_wp.wp_9ea7_wau_access'
23 'admin_neuroda_wp.wp_9ea7_wau_accounts'
161 'admin_neuroda_wp.wp_d78f_wau_access'
161 'admin_neuroda_wp.wp_d78f_wau_accounts'
Не совсем корректные запросы могут в последствии ломать саму БД
Мало что в это понимаю, но вижу что это связано с плагином WP Access Ultimate
Что тут можно сделать?
Началось такое, после как удалили много страниц в которых контент был ограничен WP Access Ultimate
Что лучше тут сделать - добавить возможно эти таблицы?
Fatal error: Uncaught Error: Call to undefined function ads_get_box() in /var/www/www-root/data/www/codeseller.ru/wp-content/themes/codeseller/includes/adv.php:15 Stack trace: #0 /var/www/www-root/data/www/codeseller.ru/wp-includes/class-wp-hook.php(310): add_adv_content_after_first_forum_post('pfm-single-post...', '/var/www/www-ro...') #1 /var/www/www-root/data/www/codeseller.ru/wp-includes/class-wp-hook.php(334): WP_Hook->apply_filters('', Array) #2 /var/www/www-root/data/www/codeseller.ru/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #3 /var/www/www-root/data/www/codeseller.ru/wp-content/plugins/wp-recall/functions/files.php(57): do_action('rcl_include_tem...', 'pfm-single-post...', '/var/www/www-ro...') #4 /var/www/www-root/data/www/codeseller.ru/wp-content/plugins/wp-recall/add-on/prime-forum/functions-templates.php(117): rcl_include_template('pfm-single-post...', '/var/www/www-ro...') #5 /var/www/www-root/data/www/codeseller.ru/wp-content/plugins/wp-recall/add-on/prime-forum/themes/prime-first/templates/pfm in /var/www/www-root/data/www/codeseller.ru/wp-content/themes/codeseller/includes/adv.php on line 15