3 ответ(ов) в теме
Сергей
не в сети 2 месяца
На сайте с 08.05.2019
Участник
Тем 2
Сообщения 6
1
12:01
Версия WP-Recall:16.17.8

Приветствую!
Изучаю сей продукт будучи молодым подаваном. Не загружался аватар к пользователю, перерыл весь форум, решение открылось после того как отключил библиотеку jquery-3.3.1.min.js. Стало появляться всплывающее окно на загрузку аватара и собственно сам аватар стал отображаться.
Есть возможность подружить плагин с Jquery? У меня карусель без этого не запускается. Теперь либо то либо другое...
Как-то так. Да пребудет с Вами сила!

0
Otshelnik-Fm
не в сети 3 часа
На сайте с 27.01.2013
Модератор
Тем 29
Сообщения 14349
2
12:19

Здравствуйте.

Вордпресс не использует jquery библиотеку версии 3. Не кажется ли вам почему он ее не использует? Потому что есть огромное кол-во плагинов и все эти плагины ориентируются на выбор движка. А он подключает jquery из своей папки версии 1.12 и jquery migrate 1.4

Так что единственный выход использовать версию jquery ту что идет в движке и загружается из его папки wp-includes так обеспечится максимальная совместимость. А две версии jquery на сайте использовать нельзя. Это явно приведет к конфликтам.

Работайте правильно. Так как заложено самой экосистемой вордпресс.

0
Сергей
не в сети 2 месяца
На сайте с 08.05.2019
Участник
Тем 2
Сообщения 6
3
13:31

ОК, Спасибо. Закрыто.

0
Тема закрыта. Публикация новых сообщений запрещена.